PC SDK 5.60 and remote controllers

Hi everyone,

I tried to use the PC SDK 5.60 version in a C# application and I found a problem.
It works perfectly with a local controller but doesn't work when there is a remote controller in the same network: the IP address of the remote controller isn't correctly detected (I got the IP "127.0.0.1" for the remote controller).
The application and the remote controller are in the same network and the firewall is off. When I use the PC SDK 5.15 version, I don't have this problem.

Can anyone help me?

Thanks in advance!

PS. I'm using virtual controllers.

Comments

  • Hi,

    I have another issue with PC SDK 5.61. I'm trying to connect with the robot, which is in the same network, and a Exception is thrown in the ControllerFactory.CreateFrom(ControllerInfo) function.

    RobotStudio .NET exception: Sequence contains no matching element
    ============================================
    Base exception: InvalidOperationException
    Sequence contains no matching element
       at System.Linq.Enumerable.First[TSource](IEnumerable`1 source, Func`2 predicate)
       at ABB.Robotics.Controllers.Internal.Controller.Initialize(String url)
       at ABB.Robotics.Controllers.Internal.ControllerManager.InternalGetController(Controller external)
       at ABB.Robotics.Controllers.Controller..ctor(String controllerID)
       at ABB.Robotics.Controllers.ControllerFactory.CreateFrom(ControllerInfo info, ControllerFactoryProperty property)
       at PruebasController.Class1.buttonNetworkScanner_ExecuteCommand(Object sender, ExecuteCommandEventArgs e)
       at ABB.Robotics.RobotStudio.Environment.CommandBarButton.<RaiseExecuteCommand>d__0.MoveNext()

    Any suggestion is welcome.
  • Prashant_Desai
    Prashant_Desai BTP, Whitefield, Bangalore

    Hello NR Martin

     

    Please install latest version of both pcsdk 5.61.01 and RobotStudio 5.61.01

    Is C# application is stand alone application or add ins to RobotStudio?

     

    Thanks and Regards,

    Prashant Desai

  • NRMartin
    NRMartin Spain
    Hello Prashant Desai,

    Thanks for your help.

    C# application is stand alone.
    I have installed PC SDK 5.61.01 and RobotStudio 5.61.01 and I get the same error.
    Here is the exception:

       en Adapters.Adapter.CreateControllerObject(String _url)
       en Adapters.Adapter..ctor(Url url)
       en Adapters.IOSystem..ctor(Url url)
       en ABB.Robotics.Controllers.Internal.AdapterCache.get_IOSystem()
       en ABB.Robotics.Controllers.Internal.IOSystem..ctor(Controller controller)
       en ABB.Robotics.Controllers.Internal.Controller.CreateObjects()
       en ABB.Robotics.Controllers.Internal.Controller..ctor(Url url)
       en ABB.Robotics.Controllers.Internal.ControllerManager.InternalGetController(Controller external)
       en ABB.Robotics.Controllers.Internal.ControllerManager.GetController(Controller external)
       en ABB.Robotics.Controllers.Controller..ctor(String controllerID)
       en ABB.Robotics.Controllers.ControllerFactory.CreateFrom(ControllerInfo info, ControllerFactoryProperty property)
       en ABB.Robotics.Controllers.ControllerFactory.CreateFrom(ControllerInfo info)
       en Prototipo.Form1.scanning() en c:\Users\Administrador\Documents\Visual Studio 2012\Projects\Prototipo_v2_\Prototipo_v2\Form1.cs:línea 1523
       en Prototipo.Form1.initializeElements() en c:\Users\Administrador\Documents\Visual Studio 2012\Projects\Prototipo_v2_\Prototipo_v2\Form1.cs:línea 310
       en Prototipo.Form1..ctor() en c:\Users\Administrador\Documents\Visual Studio 2012\Projects\Prototipo_v2_\Prototipo_v2\Form1.cs:línea 194
       en Prototipo.Program.Main() en c:\Users\Administrador\Documents\Visual Studio 2012\Projects\Prototipo_v2_\Prototipo_v2\Program.cs:línea 17
       en System.AppDomain._nExecuteAssembly(RuntimeAssembly assembly, String[] args)
       en System.AppDomain.nExecuteAssembly(RuntimeAssembly assembly, String[] args)
       en System.Runtime.Hosting.ManifestRunner.Run(Boolean checkAptModel)
       en System.Runtime.Hosting.ManifestRunner.ExecuteAsAssembly()
       en System.Runtime.Hosting.ApplicationActivator.CreateInstance(ActivationContext activationContext, String[] activationCustomData)
       en System.Runtime.Hosting.ApplicationActivator.CreateInstance(ActivationContext activationContext)
       en System.Activator.CreateInstance(ActivationContext activationContext)
       en Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssemblyDebugInZone()
       en System.Threading.ThreadHelper.ThreadStart_Context(Object state)
       en System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       en System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       en System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       en System.Threading.ThreadHelper.ThreadStart()

    Any suggestion?