Error occurs when opening simulation rsstn file in robotstudio

Options
Hello,

I have a problem with opening a *.rsstn file. The day before i modified a simulation i made with an IRB 6700. Within the simulation i placed an extra system with an IRB 660. The system with IRB 660 is a system i made before and insert it into the simulation. I copiëd all workopbjects to the IRB 660 system. After synchronizing to RAPID i copiëd the program lines from the IRB 6700 into the IRB 660. Both systems where working like i expected. After some tests i saved the simulation.

The day after i tried to open the simulation file and get the following error:
- in the output window displayed the message below.
 Unknown Error: Open (Catagory: General)

When i click on detailed information, i get the following text:
///////////////////////\\\\\\\\\\\\\\\\\\\\\\\\\
RobotStudio .NET exception: An item with the same key has already been added.
============================================
Base exception: ArgumentException
An item with the same key has already been added.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at RobotStudio.API.Core.CmMap`2.Add(TKey key, TValue value)
   at ABB.Robotics.RobotStudio.Stations.RsTask.AddToDeclarationsCache(IDeclaration declaration)
   at ABB.Robotics.RobotStudio.Stations.RsTask.AfterLoad(PimDocument doc)
   at RobotStudio.API.Persistence.PimDocument.LoadXml(Stream xmlStream, String expectedDocType, Int64 pimStreamSize, Nullable`1 requiredGuid)
   at RobotStudio.API.Persistence.PimDocument.LoadZip(Stream fileStream, Int64 fileSize, String docType, Boolean readOnly, Nullable`1 requiredGuid)
   at RobotStudio.API.Persistence.PimDocument.InternalLoad(String fileName, String docType, Boolean readOnly, Nullable`1 requiredGuid)
   at RobotStudio.API.Persistence.PimDocument.Load(String fileName, String docType, Boolean readOnly, Boolean allowExisting, Nullable`1 requiredGuid, ProgressNotification progressDelegate, Double progressStart, Double progressEnd)
   at ABB.Robotics.RobotStudio.Stations.Station.Load(String fileName, Boolean asReadOnly, ProgressNotification progressDelegate, FileNotFoundNotification fileNotFoundDelegate, Boolean loadGeometry)
   at ABBInternal.FileCommands.FileCommandServices.OpenStation(String fileName, Boolean loadGeometry)
   at ABBInternal.FileCommands.OpenStationCommandHandler.<Execute>d__0.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at ABB.Robotics.RobotStudio.Environment.CommandBarButton.<RaiseExecuteCommand>d__0.MoveNext()
///////////////////////\\\\\\\\\\\\\\\\\\\\\\\\\

I tried to load an older pack and go from the simulation and that worked. I tried to open the simulation with the error on another pc without result.

Can anyone help me to open it, or do i have to make a new simulation?

Comments

  • Daper
    Daper
    edited May 13
    Options
    Hello,

    I am facing kind of the same problem. I have a project .rsproj which contains a station file .rsstnx. From one day to the next, I could no longer open the project for no apparent reason. Neither with R2024 nor with RS2023 although this issue seems to have been corrected in RS2023 (as specified in the release notes) !
    Does anyone have a clue ?
    Any help would be appreciated 
  • Maxim Riabichev
    Options
    Hey @Daper

    I'd recommend to reach out to your local ABB and report this issue.

    Please provide as much information regarding reproduction steps as possible.

    Thanks!

    Maxim Riabichev
    PC Software Support Engineer
  • Daper
    Options
    Thank you for your reply, I will then get in touch with the local representative
  • Daper
    Options
    So I have contacted my local ABB, and the issue sounds to be a knwon one. I was recommended to uninstall/reinstall all robotstudio versions I may have.
  • Daper
    Options
    There seems to be another way to explore:
    When opening the .rrstnx file with a text editor, one can see that the file contains many lines that involve the keyword "key" such as 
    "
    <MechUnitToTask>
         <Element Key="24929">
              <Value ID="22843" />
         </Element>
         <Element Key="46914">
              <Value ID="22843" />
          </Element>
          <Element Key="46915">
              <Value ID="47272" />
          </Element>
    </MechUnitToTask>

    "
    Can it be that one of these items across the file is related to this error ?