conveyor problem in v6.02.01 (error 50174)

I'm getting the 50174 "workobject don't connected to conveyor" error, suggesting me that I need to check if I miss "WaitWObj", and if I execute "DropWObj" before the end of coordination.

But I actually have it, in fact i'm trying everything this video tells me:
https://www.youtube.com/watch?v=x3e0-_KiiQ0

This is my fourth try and I'm always stuck at the same point, when the robot moves to the piece and tries to do the auto-path it stops and then sends me the error.

I did everything as the video says and I can't get rid of this error, tried different conveyor speeds, tried duplicating WaitWObj action (that caused another kind of error, probably because it should not be duplicated) and I'm starting to think that it could be a limitation of the controller or something like that... (I'm doing everything virtually, no physical controller nor robot involved)

I'm operating with the IRB120 and Robotware 6.02.1029

Someone could help me or knows something??
Here is the unpack & go file:
https://www.dropbox.com/s/fy2tx505by3jyvy/ConveyorProblem.rspag?dl=0

Thanks in advance.

Comments

  • JoarJoar Jørpeland
    Try this.

    PROC Path_10()
       MoveL Target_10,v1000,z20,MyTool\WObj:=wobj_cnv1;
       MoveL Target_20,v1000,z10,MyTool\WObj:=wobj_cnv1;
       MoveC Target_30,Target_40,v1000,z10,MyTool\WObj:=wobj_cnv1;
       MoveC Target_50,Target_60,v1000,z10,MyTool\WObj:=wobj_cnv1;
       MoveL Target_70,v1000,z10,MyTool\WObj:=wobj_cnv1;
       MoveAbsJ pAbsHome,v1000,fine,MyTool\WObj:=wobj0;
       DropWObj wobj_cnv1;
    ENDPROC

    PROC Main2()
       MoveAbsJ pAbsHome,v1000,z100,MyTool\WObj:=wobj0;
       ActUnit CNV1;
       WaitWObj wobj_cnv1;
       Path_10;
       MoveAbsJ pAbsHome,v1000,z100,MyTool\WObj:=wobj0;
       DropWObj wobj_cnv1;
    ENDPROC
Sign In or Register to comment.