Problem in recognizing S4 Controller with RobotStudio 6.08

Hello. I'm doing an application for an academic purpose, trying to make a digital twin of an industrial system that uses an ABB IRB 1400 M98 with an S4 controller. I'm trying to use the Robotstudio to acquire the position/joint angles data of the robot via TCP/IP connection with ethernet network while the real system is operating, but I'm unable to connect with the S4 controller. On the software I'm using the IRB 1410 robot because I don't have the IRB1400 M98 available from the library. I have RAP/FactoryWare installed on the robot controller and I have RobotWare v6.08.01 Add-in installed in the Software

1. I have tried to use DHCP (doesn't seem to work), i get the error message "Please make sure your computer is connected to the controller's service port, that DHCP is enabled or that your static IP address is 192.168.125.[2...255]

2. If I try to connect directly to the controller service port or if I use static IP address I can ping the controller from the defined IP address, but when I try the connection I get the message "No controller found on Service Port. Please wait a few seconds and click retry.  Click Cancel to abort."

I have read about the PC Interface Add-in for the controller but I don't know how to check if it's available on the S4 controller that I have (its very old), but since I can ping the controller from a remote pc connected to the Ethernet I think that option is ok. I have also tried to uninstall and use a previous version (5.6) of the RS, but had the same results, so I can't find where the problem is.

Thank you very much, look forward to any reply with help.


Sign In or Register to comment.