Calibration data on multimove setup

PetrBPetrB Auckland, NZ
Hi, I have 2 robots with multimove option. When I go online with controller and check configuration file, there are calibration data only for rob1. Where can I find calibration data for second robot?

Thanks

MOC:CFG_1.0::


Comments

  • graemepaulingraemepaulin New Zealand ✭✭✭
    The data for all the robots is in the one moc.cfg file.
    Each robot has its own line in each topic.
  • PetrBPetrB Auckland, NZ
    edited July 30
    Thanks Graeme, but this is all I can see in moc.cfg file:

    MOC:CFG_1.0::
    # Serial Number: 1600-xxxx
    # Created 2020-06-17 12:38:15 by Axis Calibration
     
    # MOTOR_CALIB - ?
    MOTOR_CALIB:
    -name "rob1_1" -valid_com_offset -cal_offset 5.0554 -valid_cal_offset  \
    -factory_calibration_method 3 -latest_calibration_method 3
     
    -name "rob1_2" -valid_com_offset -cal_offset 3.5378 -valid_cal_offset  \
    -factory_calibration_method 3 -latest_calibration_method 3
     
    -name "rob1_3" -valid_com_offset -cal_offset 2.8657 -valid_cal_offset  \
    -factory_calibration_method 3 -latest_calibration_method 3
     
    -name "rob1_4" -valid_com_offset -cal_offset 2.3486 -valid_cal_offset  \
    -factory_calibration_method 3 -latest_calibration_method 3
     
    -name "rob1_5" -valid_com_offset -cal_offset 3.4281 -valid_cal_offset  \
    -factory_calibration_method 3 -latest_calibration_method 3
     
    -name "rob1_6" -valid_com_offset -cal_offset 5.8066 -valid_cal_offset  \
    -factory_calibration_method 3 -latest_calibration_method 3
     
    # ROBOT_SERIAL_NUMBER - ?
    ROBOT_SERIAL_NUMBER:
    -name "rob_1" -robot_serial_number_high_part "1600" \
    -robot_serial_number_low_part xxxx
     
    # AXIS_CALIBRATION_JOINT - ?
    AXIS_CALIBRATION_JOINT:
    -name "rob1_1" -axcal_version 1 -p1 0 -p2 -5.02642 -p3 0 \
    -p4 0 -p5 0 -p6 2 -p7 30 -p8 10 -p9 0.3 \
    -p10 0.5 -p11 0.09 -p12 1.2 -p13 0.8 -p14 0.3 \
    -p15 0.075 -p16 0.1 -p17 1 -p18 -1 -p19 -1
     
    -name "rob1_2" -axcal_version 1 -p1 0 -p2 -5.05299 -p3 0 \
    -p4 0 -p5 0 -p6 2 -p7 30 -p8 15 -p9 0.3 \
    -p10 0.5 -p11 0.09 -p12 1.2 -p13 0.9 -p14 0.3 \
    -p15 0.075 -p16 0.1 -p17 1.5 -p18 -1 -p19 -1
     
    -name "rob1_3" -axcal_version 1 -p1 -3.8 -p2 -10.9335 -p3 0 \
    -p4 13 -p5 0 -p6 2 -p7 30 -p8 15 -p9 0.12 \
    -p10 0.5 -p11 0.09 -p12 0.9 -p13 0.4 -p14 0.06 \
    -p15 0.075 -p16 0.1 -p17 1.5 -p18 -1 -p19 -1
     
    -name "rob1_4" -axcal_version 1 -p1 18.5 -p2 30.5276 -p3 0 \
    -p4 18.5 -p5 0 -p6 2 -p7 30 -p8 10 -p9 0.09 \
    -p10 0.5 -p11 0.09 -p12 0.3 -p13 0.3 -p14 0.04 \
    -p15 0.14 -p16 0.1 -p17 2 -p18 -1 -p19 -1
     
    -name "rob1_5" -axcal_version 1 -p1 2 -p2 -9.00167 -p3 0 \
    -p4 0 -p5 0 -p6 2 -p7 30 -p8 10 -p9 0.09 \
    -p10 0.8 -p11 0.09 -p12 0.5 -p13 0.2 -p14 0.07 \
    -p15 0.14 -p16 0.1 -p17 2.5 -p18 -1 -p19 -1
     
    -name "rob1_6" -axcal_version 1 -p1 104 -p2 92.3398 -p3 0 \
    -p4 100 -p5 0 -p6 2 -p7 30 -p8 10 -p9 0.16 \
    -p10 0.6 -p11 0.09 -p12 0.4 -p13 0.2 -p14 0.1 \
    -p15 0.14 -p16 0.1 -p17 5 -p18 -1 -p19 -1

  • graemepaulingraemepaulin New Zealand ✭✭✭
    Was the system delivered from the factory as a  MultiMove system or has it been retrofitted as one after the fact?
  • PetrBPetrB Auckland, NZ
    edited July 31
    Straight from factory as MultiMove. I'm not sure if I'm using right terminology with MultiMove. Basically two robots controlled by one IRC5. Same setup as in Warkworth, we did together two years ago.



  • graemepaulingraemepaulin New Zealand ✭✭✭
    edited August 2
    Try  to reset the system - under restart->advanced...
    Note if you have done any changes to the system these will be lost = take a backup first.
  • PetrBPetrB Auckland, NZ
    edited August 5
    Problem was on my side. I tried to access file in folder HOME, but it stores only config of first robot.



    moc.cfg file can be accessed through tab Controller/save parameters/motion, or

Sign In or Register to comment.