RobotStudio VR troubleshooting.

zanic07zanic07 Ferndale MI
I just received a new VR headset a few weeks ago and thought I would share how I recovered from the  VR failed to initialize fault i received and got VR to work in RobotStudio on my laptop. 

First thing first my setup
Laptop: ASUS ROG Strix Scar III
Headset: Oculus Rift S 
The headset is connected to the computer Via 1 USB 3.1 port and 1 USB type C Display-Port using a Display-Port to USB-C adapter.

Inorder to initialize VR in RobotStudio I first connected my headset and started the Oculus app. Once the headset was fully powered up and my home screen had loaded properly I opened robot studio, loaded a station, and in the home tab a new button is available in the Graphics menu that shows a black mask and the word VR underneath. 

Now here is where my first issue arose. When I clicked the VR button a loading screen popped up stating RobotStudio was loading on my headset I let it load for approx 30 minutes before noticing that in the output log an error stating VR failed to initialize: (Unknown) had popped up. 

I called ABB and was told to try uninstalling RobotStudio and reinstalling the latest version.

When I tried loading RobotStudio VR again I was met with the same error but with more information as to the cause. VR failed to initalize: Verify that RobotStudio and VR uses the same display adapter. 

To solve this I right clicked on my desktop and pressed the NVIDIA control panel. Under the 3D settings tab I pressed the manage 3D settings menu on the left hand side. This brought up a menu that allowed me to select a program settings tab where I could find RobotStudio in the drop down menu. Under section 2 you can select the preferred graphics processor for any program. I cycled through the options until I found something that mentioned my NVIDIA card and hit apply (If selecting your NVIDIA card does not work try selecting any of the other options in the preferred graphics menu).

For good measure I restarted my laptop, opened the Oculus app, opened RobotStudio and pressed the VR button and it loaded perfectly in about a minute or so.

Hopefully this can help someone. 
Sign In or Register to comment.