Arm in bad pose after restoring from someone elses' backup

ABankABank Johannesburg South Africa
edited January 14 in YuMi
We restored a backup from someone else's YuMi on ours as a last resort.
When we executed the task, the left arm oriented itself into an almost reverse/mirror configuration.

Both arms moved erratically, but we were able to move the right arm back to the default pose.

Trying to put the left arm into the normal default pose (like all the pictures of the YuMi) using lead through mode fails because the motors seem to have reset the rotation limits so that you cannot rotate the joints to where they should be.

We tried restoring our original config but that did not change anything.

We also tried doing the hall sensor calibration. for all the left arm joints. But doing this leaves the arm in a pose that it shouldn't be in (i.e 'bad'). The controller thinks everything is calibrated, which is not good. Maybe it is calibrated to a mirror position?

The 'bad' pose of the left arm is such that jogging even slightly in any direction causes collision prediction errors to occur.
We did try turning off collision prediction, and then try lead through mode, but the same problem with the motor limits is present.

I might be completely wrong about the motor rotation limits being something that can change (through firmware?), but my understanding of servo motors makes me think this is the case.

Is there a way to reset/ turn off the motor limits so that I can rotate the joints into their correct orientations?

Context:
We are trying to get YuMi to work with ROS. The instructions to do this are outdated and unclear. As a last resort, we restored from backups we found on the Github repo of the instructions. Bad idea... :'(

Post edited by ABank on

Comments

  • ABB_YuMiGuideABB_YuMiGuide ABB Cobot Solution Centre admin
    Hello,
    First of all, create a backup and then perform a I-start to Factory reset the system. Then check, if the jogging issue persists, move YuMi's arm (only left arm) to calibration position, if it is impossible to move the arms with literal or jogging, just turn off the motors and use the Brake release buttons. After this, perform the call hall procedure and select Fine Calibration instead of Revolution Counter Update and provide us with the backup of the robot. Also, please provide a picture of the calibrated YuMi arm position. We will investigate the issue if this procedure does not work.
    Best of Luck!
  • ABankABank Johannesburg South Africa
    Hi thank you for your help. I missed your post as I didn't set email notifications for this thread.

    We will try the suggested procedure tomorrow and report back.

    Thanks so much!
  • ABankABank Johannesburg South Africa
    edited February 10
    It worked!




    Learning about the brake release buttons was key.

    I can upload our backup (the one we made before fixing the arm) if you would still like to take a look, but it is definitely fixed now.
    Thank you so much for your help!

  • ABB_YuMiGuideABB_YuMiGuide ABB Cobot Solution Centre admin
    I am glad that it worked! Hopefully you will not face any other issues. In case you have any questions, let me know. 
Sign In or Register to comment.