RobotStudio event

3DConnexion mouse in RS 6.03


I just got a 3DConnexion spacenavigator from a colleague. I installed all the drivers and the mouse is working great in many applications. Unfortunately, in RobotStudio I can only zoom in an out with the mouse, although all the other options are activated.
I tried to edit commands in the "customize commands" window, or from the options window but I couldn't find anything related. 
Anyone here knows how to activate all the other options to move around freely in the simulation?

Thanks :)

Best regards,


  • Hmm. Mine just worked after I installed it. didn't have to activate anything. 
  • What version of RobotStudio are you working with if I may ask you?
  • hmm I think I have 5.15, 5.60, 6.0, 6.01, 6.02 and 6.03
  • I'll try installing an older version of RS. Keep you posted

  • I have installed different versions of RobotStudio, without success. My colleague is dealing with the same issues as I described above. I guess we just have to stick to the ordinary mouse and keyboard
  • Neily03
    Neily03 ✭✭✭
    Are you using the latest drivers from 3Dconnexion?
  • It should "just work". Which OS and driver version are you using? Have you tested it with other apps?
    Johannes Weiman
    Software Engineer
    RobotStudio Team, ABB Robotics
  • I have downloaded the latest drivers from the website here: I'm running windows 10 (my colleague windows 7). I also tested it with other apps and there the functionalities do work. From next week on I'm back at the office, I can give more detailed information about drivers etc. then. Thanks for your efforts.
  • I've just open the box of mine and install it. It's working fine on RS 6.04.01....  I don't know if there is a way to change how the mouse move the 3d models on RS....

    Un saludokind regards,

    Daniel Aguilar

    Automation Engineering

  • Hi

    Don't want to open additional discussion, so...
    RobotStudio 2020.2 (64-bit)
    Version 20.2.9116.0
    3D Connxion SpaceMouse

    Mouse works good, but I am wondering how to switch betwwen controlling 1-3 axis and 4-6 axis while using that mouse - same as on flexpendand. On default I can control only 1-3 axis. If I try to switch it be virtual flexpendand it does not take effect.

  • Found an answer to the problem, if anyone needs that as well: instruction in attachemnt - thanks to PolyRobotics company. 
  • Newman
    edited October 2021
    Solution for me in image below.

    I had the exact same problem with my brand new 3dconnexion spacemouse today with RS2021.2 and latest drivers etc. Spacemouse would only zoom in/out but was working fine in the 3dconnexion demo viewer.
    After "reset all settings" it started to work.

    Swedish freelance ABB robot programmer