Test running program from FlexPendant

bhanscombhanscom United States

I have an active program loaded into RS5.07 that I am trying to test run using the Virtual Flex Pendant without any success.  The problem is that when I try move the program pointer to the routine that I am trying to run, if I step through the routine, when I try to run a Move instruction, I get error messages stating that the client may not be in control and that required mastership could not be granted.

error message number: 20051

Could anyone explain what exactly is going on here and how to correct it?

Thanks,

Brian

Comments

  • Anders SAnders S Sweden mod

    Hi Brian,

    Unfortunately can this  sometimes happen in RS 5.07. Normally will a warmstart of the VirtualController solve it.

    We are working on this problem for future releases.

     

     

    Best regards,
    Anders Spaak
    ABB Robotics
  • ColeCole Australia
    I have been getting this problem with RS5.08 and warmstarts do not fix.

    Has anyone found what is causing it?

    "Argon Technology - your industrial robotics and automation partner, helping you build your tomorrow"
  • sturnersturner United Kingdom ✭✭

    I am also getting this problm in 5.08.

    I can not run the program from the Flexpendant and get Client not in controll errors. Write Access has not been resquested in RSO and I am not testing reachability in the station.

    This is very very very annoying !

    I need an explanation what to do next!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!